Follow

What do I need to start using Spuul?

On Your Computer:
You’ll need the latest browser for a smooth experience on Spuul.

Firefox 9.0 or higher. Get the latest version of Firefox here.

Safari 5.1 or higher. Get the latest version of Safari here.

Chrome 17 or higher.

Get the latest version of Chrome here.

You’ll also need the have Adobe Flash Player 11.3 or higher installed. Get the latest version of Adobe Flash here. JavaScript and Cookies must be enabled on your browser.

Once you've found Spuul on the browser of your choice, you will need to create an account on Spuul to watch movies. 

An internet connection is also necessary (obviously). You’ll need a minimum of 300kbps downstream but we recommend having at least 1.5mbps for a smooth playback experience.